Destination:\ SharePoint > Destination:\ SharePoint 2013 > Posts > Handling Errors while installing (Stand-Alone) SharePoint 2013
July 17
Handling Errors while installing (Stand-Alone) SharePoint 2013

While installing SharePoint 2013 for a Stand-Alone setup on a non-domain based VM you might encounter some issues.

The errors I had were -

  1. Service running under Network Service Account in workgroup environment is not supported
  2. ErrorCode<UnspecifiedErrorCode>: SubStatus <ES0001>: The Workstation service has not been started
  3. The SDDL string contains an invalid sid or a sid that cannot be translated. Parameter name: sddlForm

So, here are some useful tips that can help you in fixing them. You don’t need to do all the below of course. See the relevant issue you are having and then fix it accordingly. For convenience, I am adding screen shots of various errors that I got while installing it. Trust me, I was not able to install it right first time -

  • Stand-Alone option will install SQL Server Express Edition on the VM and user installing must have sufficient rights (Setup admin) on the database. In order to give the permissions / rights, install SQL Server 2008 R2 Management Studio and provide access as shown below. Access the below from you SQL Server Management Studio (.\SharePoint instance) > Security > Logins > {logged in user account} > Server Roles >

 

  • Services required to run the Configuration Wizard
    1. AppFabric Caching Service
    2. SQL Server Agent (SHAREPOINT)
    3. Workstation - need to be started.
  • run the following PSConfig command to create configuration database with out registering distributed cache host.
    PS: You need to run the Configuration Wizard once again since the below command will not run the configuration fully.

       1:  psconfig.exe -cmd Configdb Create SkipRegisterAsDistributedCacheHost


     
  • And here are some errors I have encountered for your reference. I have made sure that every time there was an error, I did go to the log file, verified the internals. 

     

     

Comments

Hum....

Good tip
 on 7/18/2012 12:59 PM

Problem with Failed to create sample data

Hi and Thanks this article. But now i'm stuck at the Failed to create sample data error. Can you help me with a possible solution? Thanks in advance!
 on 7/30/2012 3:55 PM

Supremely helpful article

I followed the troubleshooting instructions, and I now have a working version of SP 2013.
 on 8/5/2012 4:08 PM